Return Statement in a Function

Kemarin siang setelah makan nasi campur Kenanga di Central Park harus segera balik lagi ke kantor untuk bug fixing. Ada function di file javascript yang perlu enhancement serta bug fixing. Namun akhirnya malah jengkel sendiri saat membaca script programmer yang terdahulu. Case yang sering membuat blunder, sebagai contoh adalah coding model seperti di bawah ini :

function doSomething(){
	something = yourValue;
	if(condition){
		something = yourUpdatedValue;
		return something;
	}
	return something;
}

Damn you! Kalo moodnya sedang prima sebetulnya enak bacanya. Tapi ketika sedang spaneng mengejar deadline dan urgent untuk membantu BC, justru malah jadi bingung plus pusing. Kenapa tidak diketik dengan konsisten agar lebih rapi? In example :

function doSomething(){
	something = yourValue;
	if(condition){
		something = yourUpdatedValue;
	}
	else{
		something = keepYourValue;
	}
	return something;
}

It’s seems more readable, lebih rapi, lebih berasa sequencenya. Kalo ya maka tidak, jangan ketika ya terkesan lanjut tapi ternyata tidak. Tapi bener tidak sih yang snippet di atas itu sebenarnya equivalen? Bagaimana dengan pendapat dari teman-teman? Kembali ke kebiasaan masing-masing. Kalau saya sih iyess lebih suka sesuatu yang meski terlihat panjang tapi readable 😀

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.